PHP 7.0.x < 7.0.23 Heap-based Buffer Overflow Vulnerability

critical Nessus Plugin ID 122539
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The version of PHP running on the remote web server is affected by a heap-based buffer overflow vulnerability.

Description

According to its banner, the version of PHP running on the remote web server is 7.0.x prior to 7.0.23. It is, therefore, affected by a heap-based buffer overflow condition exists in the ext/standard/var_unserializer.re script due to improper use of the hash API for key deletion. An unauthenticated, remote attacker can exploit this to cause a denial of service condition or the execution of arbitrary code.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 7.0.23 or later.

See Also

http://php.net/ChangeLog-7.php#7.0.23

Plugin Details

Severity: Critical

ID: 122539

File Name: php_7_0_23.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 3/1/2019

Updated: 10/31/2019

Dependencies: php_version.nasl

Risk Information

CVSS Score Source: CVE-2017-12932

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Required KB Items: www/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 8/31/2017

Vulnerability Publication Date: 8/17/2017

Reference Information

CVE: CVE-2017-12932

BID: 100427