MongoDB 3.4.x < 3.4.10 / 3.5.x < 3.6.0-rc0 mongod

Medium Nessus Plugin ID 122363


The remote database server is affected by a vulnerability that may result in a denial of service or in the compromise of the server memory integrity.


The version of the remote MongoDB server is 3.4.x prior to 3.4.10 / 3.5.x prior to 3.6.0-rc0. It is, therefore, affected by a denial of service vulnerability in mongod networkMessageCompressors due to an implementation error. A remote, unauthenticated attacker can exploit this, to cause a denial of service or to modify server memory.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to MongoDB version 3.4.10 / 3.6.0-rc0 or later.

See Also

Plugin Details

Severity: Medium

ID: 122363

File Name: mongodb_3_6_0-rc0.nasl

Version: 1.1

Type: remote

Family: Databases

Published: 2019/02/21

Updated: 2019/02/21

Dependencies: 65914

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2017-15535

CVSS v2.0

Base Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:P

CVSS v3.0

Base Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H

Vulnerability Information

CPE: cpe:/a:mongodb:mongodb

Required KB Items: Services/mongodb

Patch Publication Date: 2017/10/31

Vulnerability Publication Date: 2017/10/31

Reference Information

CVE: CVE-2017-15535

BID: 101689