MongoDB 2.6.x < 2.6.9, 3.0.x < 3.0.14, 3.2.x < 3.2.8 mongod

High Nessus Plugin ID 122243

Synopsis

The remote database server is affected by a vulnerability that may result in a denial of service or in the compromise of the server memory integrity.

Description

The version of the remote MongoDB server is 2.6.x prior to 2.6.9, is 3.0.x < 3.0.14 or is 3.2.x < 3.2.8. It is, therefore, affected by multiple vulnerabilities.

- A credentials disclosure vulnerability exists in the PEMKeyPassword, clusterPassword and Windows servicePassword. An unauthenticated local attacker can exploit this to get access to user credentials. (CVE-2014-2917)

- A denial of service (DoS) vulnerability exist in the CmdAuthenticate::_authenticateX509 function in db/commands/authentication_commands.cpp in mongod. An unauthenticated remote attacker can exploit this to cause a denial of service (daemon crash) by attempting authentication with an invalid X.509 client certificate. (CVE-2014-3971)

- A heap-based buffer overflow condition exists in PCRE. An unauthenticated remote attacker can exploit this via a crafted regular expression, related to an assertion that allows zero repeats to cause a denial of service or to cause other unspecified impact. (CVE-2014-8964)

- A DoS vulnerability exists due to failure to check for missing values. An authenticated remote attacker can exploit this to cause the application to crash. The attacker needs write access to a database to be able to exploit this vulnerability.
(CVE-2015-2705)

- A breach of data integrity vulnerability exists in the WiredTiger storage engine. An authenticated remote attacker can exploit this by issuing an admin command to write statistic logs to a specific file and may compromise data integrity. (CVE-2017-12926)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to MongoDB version 2.6.9 / 3.0.14 / 3.2.8 or later.

See Also

https://jira.mongodb.org/browse/SERVER-13644

https://jira.mongodb.org/browse/SERVER-13753

https://jira.mongodb.org/browse/SERVER-17252

https://jira.mongodb.org/browse/SERVER-17521

https://jira.mongodb.org/browse/WT-2711

https://www.mongodb.com/alerts

Plugin Details

Severity: High

ID: 122243

File Name: mongodb_3_2_8.nasl

Version: 1.2

Type: remote

Family: Databases

Published: 2019/02/15

Updated: 2019/03/27

Dependencies: 65914

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2014-2917

CVSS v2.0

Base Score: 7.2

Temporal Score: 6.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 9.3

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:mongodb:mongodb

Required KB Items: Services/mongodb

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/05/05

Vulnerability Publication Date: 2014/04/17

Reference Information

CVE: CVE-2014-2917, CVE-2014-3971, CVE-2014-8964, CVE-2015-2705, CVE-2017-12926

BID: 71206