SUSE SLES12 Security Update : LibVNCServer (SUSE-SU-2019:0313-1)

High Nessus Plugin ID 122092

Synopsis

The remote SUSE host is missing one or more security updates.

Description

This update for LibVNCServer fixes the following issues :

Security issues fixed :

CVE-2018-20749: Fixed a heap out of bounds write vulnerability in
rfbserver.c (bsc#1123828)

CVE-2018-20750: Fixed a heap out of bounds write vulnerability in
rfbserver.c (bsc#1123832)

CVE-2018-20748: Fixed multiple heap out-of-bound writes in VNC client
code (bsc#1123823)

Note that Tenable Network Security has extracted the preceding
description block directly from the SUSE security advisory. Tenable
has attempted to automatically clean and format it as much as possible
without introducing additional issues.

Solution

To install this SUSE Security Update use the SUSE recommended
installation methods like YaST online_update or 'zypper patch'.

Alternatively you can run the command listed for your product :

SUSE OpenStack Cloud 7:zypper in -t patch
SUSE-OpenStack-Cloud-7-2019-313=1

SUSE Linux Enterprise Software Development Kit 12-SP4:zypper in -t
patch SUSE-SLE-SDK-12-SP4-2019-313=1

SUSE Linux Enterprise Software Development Kit 12-SP3:zypper in -t
patch SUSE-SLE-SDK-12-SP3-2019-313=1

SUSE Linux Enterprise Server for SAP 12-SP2:zypper in -t patch
SUSE-SLE-SAP-12-SP2-2019-313=1

SUSE Linux Enterprise Server 12-SP4:zypper in -t patch
SUSE-SLE-SERVER-12-SP4-2019-313=1

SUSE Linux Enterprise Server 12-SP3:zypper in -t patch
SUSE-SLE-SERVER-12-SP3-2019-313=1

SUSE Linux Enterprise Server 12-SP2-LTSS:zypper in -t patch
SUSE-SLE-SERVER-12-SP2-2019-313=1

SUSE Linux Enterprise Server 12-SP2-BCL:zypper in -t patch
SUSE-SLE-SERVER-12-SP2-BCL-2019-313=1

SUSE Linux Enterprise Server 12-SP1-LTSS:zypper in -t patch
SUSE-SLE-SERVER-12-SP1-2019-313=1

SUSE Linux Enterprise Server 12-LTSS:zypper in -t patch
SUSE-SLE-SERVER-12-2019-313=1

SUSE Enterprise Storage 4:zypper in -t patch SUSE-Storage-4-2019-313=1

See Also

https://bugzilla.suse.com/show_bug.cgi?id=1123823

https://bugzilla.suse.com/show_bug.cgi?id=1123828

https://bugzilla.suse.com/show_bug.cgi?id=1123832

https://www.suse.com/security/cve/CVE-2018-20748/

https://www.suse.com/security/cve/CVE-2018-20749/

https://www.suse.com/security/cve/CVE-2018-20750/

http://www.nessus.org/u?85b61ab2

Plugin Details

Severity: High

ID: 122092

File Name: suse_SU-2019-0313-1.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2019/02/11

Modified: 2019/02/11

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:LibVNCServer-debugsource, p-cpe:/a:novell:suse_linux:libvncclient0, p-cpe:/a:novell:suse_linux:libvncclient0-debuginfo, p-cpe:/a:novell:suse_linux:libvncserver0, p-cpe:/a:novell:suse_linux:libvncserver0-debuginfo, cpe:/o:novell:suse_linux:12

Patch Publication Date: 2019/02/09

Vulnerability Publication Date: 2019/01/30

Reference Information

CVE: CVE-2018-20748, CVE-2018-20749, CVE-2018-20750