Debian DSA-4386-1 : curl - security update

High Nessus Plugin ID 121628

Synopsis

The remote Debian host is missing a security-related update.

Description

Multiple vulnerabilities were discovered in cURL, an URL transfer
library.

- CVE-2018-16890
Wenxiang Qian of Tencent Blade Team discovered that the
function handling incoming NTLM type-2 messages does not
validate incoming data correctly and is subject to an
integer overflow vulnerability, which could lead to an
out-of-bounds buffer read.

- CVE-2019-3822
Wenxiang Qian of Tencent Blade Team discovered that the
function creating an outgoing NTLM type-3 header is
subject to an integer overflow vulnerability, which
could lead to an out-of-bounds write.

- CVE-2019-3823
Brian Carpenter of Geeknik Labs discovered that the code
handling the end-of-response for SMTP is subject to an
out-of-bounds heap read.

Solution

Upgrade the curl packages.

For the stable distribution (stretch), these problems have been fixed
in version 7.52.1-5+deb9u9.

See Also

https://security-tracker.debian.org/tracker/CVE-2018-16890

https://security-tracker.debian.org/tracker/CVE-2019-3822

https://security-tracker.debian.org/tracker/CVE-2019-3823

https://security-tracker.debian.org/tracker/source-package/curl

https://packages.debian.org/source/stretch/curl

https://www.debian.org/security/2019/dsa-4386

Plugin Details

Severity: High

ID: 121628

File Name: debian_DSA-4386.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2019/02/07

Modified: 2019/02/11

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:curl, cpe:/o:debian:debian_linux:9.0

Patch Publication Date: 2019/02/06

Vulnerability Publication Date: 2019/02/06

Reference Information

CVE: CVE-2018-16890, CVE-2019-3822, CVE-2019-3823

DSA: 4386