SUSE SLED15 / SLES15 Security Update : systemd (SUSE-SU-2019:0137-1)

high Nessus Plugin ID 121304
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote SUSE host is missing one or more security updates.

Description

This update for systemd provides the following fixes :

Security issues fixed :

CVE-2018-16864, CVE-2018-16865: Fixed two memory corruptions through attacker-controlled alloca()s (bsc#1120323)

CVE-2018-16866: Fixed an information leak in journald (bsc#1120323)

CVE-2018-6954: Fix mishandling of symlinks present in non-terminal path components (bsc#1080919)

Fixed an issue during system startup in relation to encrypted swap disks (bsc#1119971)

Non-security issues fixed: pam_systemd: Fix 'Cannot create session:
Already running in a session' (bsc#1111498)

systemd-vconsole-setup: vconsole setup fails, fonts will not be copied to tty (bsc#1114933)

systemd-tmpfiles-setup: symlinked /tmp to /var/tmp breaking multiple units (bsc#1045723)

Fixed installation issue with /etc/machine-id during update (bsc#1117063)

btrfs: qgroups are assigned to parent qgroups after reboot (bsc#1093753)

logind: Stop managing VT switches if no sessions are registered on that VT. (bsc#1101591)

udev: Downgrade message when settting inotify watch up fails.
(bsc#1005023)

udev: Ignore the exit code of systemd-detect-virt for memory hot-add.
In SLE-12-SP3, 80-hotplug-cpu-mem.rules has a memory hot-add rule that uses systemd-detect-virt to detect non-zvm environment. The systemd-detect-virt returns exit failure code when it detected _none_ state. The exit failure code causes that the hot-add memory block can not be set to online. (bsc#1076696)

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or 'zypper patch'.

Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-137=1

SUSE Linux Enterprise Module for Basesystem 15:zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-137=1

See Also

https://bugzilla.suse.com/show_bug.cgi?id=1005023

https://bugzilla.suse.com/show_bug.cgi?id=1045723

https://bugzilla.suse.com/show_bug.cgi?id=1076696

https://bugzilla.suse.com/show_bug.cgi?id=1080919

https://bugzilla.suse.com/show_bug.cgi?id=1093753

https://bugzilla.suse.com/show_bug.cgi?id=1101591

https://bugzilla.suse.com/show_bug.cgi?id=1111498

https://bugzilla.suse.com/show_bug.cgi?id=1114933

https://bugzilla.suse.com/show_bug.cgi?id=1117063

https://bugzilla.suse.com/show_bug.cgi?id=1119971

https://bugzilla.suse.com/show_bug.cgi?id=1120323

https://www.suse.com/security/cve/CVE-2018-16864/

https://www.suse.com/security/cve/CVE-2018-16865/

https://www.suse.com/security/cve/CVE-2018-16866/

https://www.suse.com/security/cve/CVE-2018-6954/

http://www.nessus.org/u?f97bddbc

Plugin Details

Severity: High

ID: 121304

File Name: suse_SU-2019-0137-1.nasl

Version: 1.4

Type: local

Agent: unix

Published: 1/22/2019

Updated: 1/13/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: High

Base Score: 7.2

Temporal Score: 5.6

Vector: AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 7

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:libsystemd0, p-cpe:/a:novell:suse_linux:libsystemd0-32bit, p-cpe:/a:novell:suse_linux:libsystemd0-32bit-debuginfo, p-cpe:/a:novell:suse_linux:libsystemd0-debuginfo, p-cpe:/a:novell:suse_linux:libsystemd0-mini, p-cpe:/a:novell:suse_linux:libsystemd0-mini-debuginfo, p-cpe:/a:novell:suse_linux:libudev-devel, p-cpe:/a:novell:suse_linux:libudev-mini-devel, p-cpe:/a:novell:suse_linux:libudev-mini1, p-cpe:/a:novell:suse_linux:libudev-mini1-debuginfo, p-cpe:/a:novell:suse_linux:libudev1, p-cpe:/a:novell:suse_linux:libudev1-32bit, p-cpe:/a:novell:suse_linux:libudev1-32bit-debuginfo, p-cpe:/a:novell:suse_linux:libudev1-debuginfo, p-cpe:/a:novell:suse_linux:nss-myhostname, p-cpe:/a:novell:suse_linux:nss-myhostname-debuginfo, p-cpe:/a:novell:suse_linux:nss-mymachines, p-cpe:/a:novell:suse_linux:nss-mymachines-debuginfo, p-cpe:/a:novell:suse_linux:nss-systemd, p-cpe:/a:novell:suse_linux:nss-systemd-debuginfo, p-cpe:/a:novell:suse_linux:systemd, p-cpe:/a:novell:suse_linux:systemd-32bit, p-cpe:/a:novell:suse_linux:systemd-32bit-debuginfo, p-cpe:/a:novell:suse_linux:systemd-container, p-cpe:/a:novell:suse_linux:systemd-container-debuginfo, p-cpe:/a:novell:suse_linux:systemd-coredump, p-cpe:/a:novell:suse_linux:systemd-coredump-debuginfo, p-cpe:/a:novell:suse_linux:systemd-debuginfo, p-cpe:/a:novell:suse_linux:systemd-debugsource, p-cpe:/a:novell:suse_linux:systemd-devel, p-cpe:/a:novell:suse_linux:systemd-logger, p-cpe:/a:novell:suse_linux:systemd-mini, p-cpe:/a:novell:suse_linux:systemd-mini-container-mini, p-cpe:/a:novell:suse_linux:systemd-mini-container-mini-debuginfo, p-cpe:/a:novell:suse_linux:systemd-mini-coredump-mini, p-cpe:/a:novell:suse_linux:systemd-mini-coredump-mini-debuginfo, p-cpe:/a:novell:suse_linux:systemd-mini-debuginfo, p-cpe:/a:novell:suse_linux:systemd-mini-debugsource, p-cpe:/a:novell:suse_linux:systemd-mini-devel, p-cpe:/a:novell:suse_linux:systemd-mini-sysvinit, p-cpe:/a:novell:suse_linux:systemd-sysvinit, p-cpe:/a:novell:suse_linux:udev, p-cpe:/a:novell:suse_linux:udev-debuginfo, p-cpe:/a:novell:suse_linux:udev-mini, p-cpe:/a:novell:suse_linux:udev-mini-debuginfo, cpe:/o:novell:suse_linux:15

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 1/21/2019

Vulnerability Publication Date: 2/13/2018

Reference Information

CVE: CVE-2018-16864, CVE-2018-16865, CVE-2018-16866, CVE-2018-6954