openSUSE Security Update : LibVNCServer (openSUSE-2019-53)

High Nessus Plugin ID 121282

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 5.9

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for LibVNCServer fixes the following issues :

Security issues fixed :

- CVE-2018-15126: Fixed use-after-free in file transfer extension (bsc#1120114)

- CVE-2018-6307: Fixed use-after-free in file transfer extension server code (bsc#1120115)

- CVE-2018-20020: Fixed heap out-of-bound write inside structure in VNC client code (bsc#1120116)

- CVE-2018-15127: Fixed heap out-of-bounds write in rfbserver.c (bsc#1120117)

- CVE-2018-20019: Fixed multiple heap out-of-bound writes in VNC client code (bsc#1120118)

- CVE-2018-20023: Fixed information disclosure through improper initialization in VNC Repeater client code (bsc#1120119)

- CVE-2018-20022: Fixed information disclosure through improper initialization in VNC client code (bsc#1120120)

- CVE-2018-20024: Fixed NULL pointer dereference in VNC client code (bsc#1120121)

- CVE-2018-20021: Fixed infinite loop in VNC client code (bsc#1120122)

This update was imported from the SUSE:SLE-15:Update update project.

Solution

Update the affected LibVNCServer packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1120114

https://bugzilla.opensuse.org/show_bug.cgi?id=1120115

https://bugzilla.opensuse.org/show_bug.cgi?id=1120116

https://bugzilla.opensuse.org/show_bug.cgi?id=1120117

https://bugzilla.opensuse.org/show_bug.cgi?id=1120118

https://bugzilla.opensuse.org/show_bug.cgi?id=1120119

https://bugzilla.opensuse.org/show_bug.cgi?id=1120120

https://bugzilla.opensuse.org/show_bug.cgi?id=1120121

https://bugzilla.opensuse.org/show_bug.cgi?id=1120122

Plugin Details

Severity: High

ID: 121282

File Name: openSUSE-2019-53.nasl

Version: 1.4

Type: local

Agent: unix

Published: 2019/01/22

Updated: 2020/09/22

Dependencies: 12634

Risk Information

Risk Factor: High

VPR Score: 5.9

CVSS Score Source: CVE-2018-20020

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:LibVNCServer-debugsource, p-cpe:/a:novell:opensuse:LibVNCServer-devel, p-cpe:/a:novell:opensuse:libvncclient0, p-cpe:/a:novell:opensuse:libvncclient0-debuginfo, p-cpe:/a:novell:opensuse:libvncserver0, p-cpe:/a:novell:opensuse:libvncserver0-debuginfo, cpe:/o:novell:opensuse:15.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/03/23

Vulnerability Publication Date: 2018/12/19

Reference Information

CVE: CVE-2018-15126, CVE-2018-15127, CVE-2018-20019, CVE-2018-20020, CVE-2018-20021, CVE-2018-20022, CVE-2018-20023, CVE-2018-20024, CVE-2018-6307