MySQL 5.6.x < 5.6.43 Multiple Vulnerabilities (Jan 2019 CPU)

Medium Nessus Plugin ID 121227

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL running on the remote host is 5.6.x prior to 5.6.43. It is, therefore, affected by multiple vulnerabilities, including three of the top vulnerabilities below, as noted in the January 2019 Critical Patch Update advisory:

- An unspecified vulnerability in MySQL in the 'Server: Replication' subcomponent could allow an low privileged attacker with network access via multiple protocols to gain unauthorized access critical data or complete access to all MySQL server data. (CVE-2019-2534)

- An unspecified vulnerability in MySQL in the 'Server: Optimizer' subcomponent could allow an low privileged attacker with network access via multiple protocols to perform a denial of service attack.
(CVE-2019-2529)

- An unspecified vulnerability in MySQL in the 'Server: PS' subcomponent could allow an low privileged attacker with network access via multiple protocols to perform a denial of service attack.
(CVE-2019-2482)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to MySQL version 5.6.43 or later.

See Also

https://dev.mysql.com/doc/relnotes/mysql/5.6/en/news-5-6-43.html

http://www.nessus.org/u?799b2d05

Plugin Details

Severity: Medium

ID: 121227

File Name: mysql_5_6_43.nasl

Version: 1.5

Type: remote

Family: Databases

Published: 2019/01/17

Updated: 2019/10/31

Dependencies: 10719, 91823

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2019-2534

CVSS v2.0

Base Score: 5.5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.1

Temporal Score: 6.2

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2019/01/15

Reference Information

CVE: CVE-2018-0734, CVE-2018-3123, CVE-2019-2455, CVE-2019-2481, CVE-2019-2482, CVE-2019-2503, CVE-2019-2507, CVE-2019-2529, CVE-2019-2531, CVE-2019-2534, CVE-2019-2537

BID: 105758, 106619, 106626, 106628