Apache Tomcat < 6.0.6 Cross-Site Scripting

Low Nessus Plugin ID 121114

Synopsis

The remote Apache Tomcat server is affected by a cross-site scripting vulnerability.

Description

According to its self-reported version number, the Apache Tomcat instance listening on the remote host is prior to 6.0.6. It is, therefore, affected by the following vulnerability :

- A cross-site scripting (XSS) vulnerability exists due to improper validation of user-supplied input before returning it to users. An unauthenticated, remote attacker can exploit this, by convincing a user to click a specially crafted URL, to execute arbitrary script code in a user's browser session.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 6.0.6 or later.

See Also

http://tomcat.apache.org/security-6.html#Fixed_in_Apache_Tomcat_6.0.6

Plugin Details

Severity: Low

ID: 121114

File Name: tomcat_6_0_6.nasl

Version: 1.2

Type: remote

Family: Web Servers

Published: 2019/01/11

Updated: 2019/03/27

Dependencies: 39446

Risk Information

Risk Factor: Low

CVSS Score Source: CVE-2007-1358

CVSS v2.0

Base Score: 2.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:P/A:N

CVSS v3.0

Base Score: 4.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Patch Publication Date: 2006/12/18

Vulnerability Publication Date: 2006/12/18

Reference Information

CVE: CVE-2007-1358

CWE: 79