openSUSE Security Update : singularity (openSUSE-2019-9)

High Nessus Plugin ID 121090

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for singularity to version 2.6.1 fixes the following
issues :

Security issues fixed :

- CVE-2018-19295: Fixed a local root exploit, related to
joining arbitrary mount namespaces (boo#1111411).

Solution

Update the affected singularity packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1111411

Plugin Details

Severity: High

ID: 121090

File Name: openSUSE-2019-9.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2019/01/11

Modified: 2019/01/25

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libsingularity1, p-cpe:/a:novell:opensuse:libsingularity1-debuginfo, p-cpe:/a:novell:opensuse:singularity, p-cpe:/a:novell:opensuse:singularity-debuginfo, p-cpe:/a:novell:opensuse:singularity-debugsource, p-cpe:/a:novell:opensuse:singularity-devel, cpe:/o:novell:opensuse:15.0

Patch Publication Date: 2019/01/10

Reference Information

CVE: CVE-2018-19295