Fedora 28 : webkit2gtk3 (2018-97c58e29e4)

Medium Nessus Plugin ID 120639

Synopsis

The remote Fedora host is missing a security update.

Description

This update addresses the following vulnerabilities :

- [CVE-2018-4200](https://cve.mitre.org/cgi-bin/cvename.cg i?name=CVE-2018-4200)

Additional fixes :

- Do TLS error checking on GTlsConnection::accept-certificate to finish the load earlier in case of errors.

- Properly close the connection to the nested wayland compositor in the Web Process.

- Avoid painting backing stores for zero-opacity layers.

- Fix downloads started by context menu failing in some websites due to missing user agent HTTP header.

- Fix video unpause when GStreamerGL is disabled.

- Fix several GObject introspection annotations.

- Update user agent quirks to fix Outlook.com and Chase.com.

- Fix several crashes and rendering issues.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora update system website.
Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected webkit2gtk3 package.

See Also

https://bodhi.fedoraproject.org/updates/FEDORA-2018-97c58e29e4

Plugin Details

Severity: Medium

ID: 120639

File Name: fedora_2018-97c58e29e4.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2019/01/03

Updated: 2019/04/02

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:webkit2gtk3, cpe:/o:fedoraproject:fedora:28

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/05/11

Reference Information

CVE: CVE-2018-4200