CVE-2018-4200

MEDIUM

Description

An issue was discovered in certain Apple products. iOS before 11.3.1 is affected. Safari before 11.1 is affected. iCloud before 7.5 on Windows is affected. iTunes before 12.7.5 on Windows is affected. tvOS before 11.4 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site that triggers a WebCore::jsElementScrollHeightGetter use-after-free.

References

http://www.securityfocus.com/bid/103961

http://www.securitytracker.com/id/1040743

https://bugs.chromium.org/p/project-zero/issues/detail?id=1525

https://security.gentoo.org/glsa/201808-04

https://support.apple.com/HT208741

https://support.apple.com/HT208743

https://support.apple.com/HT208850

https://support.apple.com/HT208852

https://support.apple.com/HT208853

https://usn.ubuntu.com/3640-1/

https://www.exploit-db.com/exploits/44566/

Details

Source: MITRE

Published: 2018-06-08

Updated: 2019-03-07

Type: CWE-416

Risk Information

CVSS v2.0

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH