Fedora 29 : php (2018-7ebfe1e6f2)

high Nessus Plugin ID 120566
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Fedora host is missing a security update.

Description

**PHP version 7.2.13** (06 Dec 2018)

**ftp:**

- Fixed bug php#77151 (ftp_close(): SSL_read on shutdown).
(Remi)

**CLI:**

- Fixed bug php#77111 (php-win.exe corrupts unicode symbols from cli parameters). (Anatol)

**Fileinfo:**

- Fixed bug php#77095 (slowness regression in 7.2/7.3 (compared to 7.1)). (Anatol)

**iconv:**

- Fixed bug php#77147 (Fixing 60494 ignored ICONV_MIME_DECODE_CONTINUE_ON_ERROR). (cmb)

**Core:**

- Fixed bug php#77231 (Segfault when using convert.quoted-printable-encode filter). (Stas)

**IMAP:**

- Fixed bug php#77153 (imap_open allows to run arbitrary shell commands via mailbox parameter). (Stas)

**ODBC:**

- Fixed bug php#77079 (odbc_fetch_object has incorrect type signature). (Jon Allen)

**Opcache:**

- Fixed bug php#77058 (Type inference in opcache causes side effects). (Nikita)

- Fixed bug php#77092 (array_diff_key() - segmentation fault). (Nikita)

**Phar:**

- Fixed bug php#77022 (PharData always creates new files with mode 0666). (Stas)

- Fixed bug php#77143 (Heap Buffer Overflow (READ: 4) in phar_parse_pharfile). (Stas)

**PGSQL:**

- Fixed bug php#77047 (pg_convert has a broken regex for the 'TIME WITHOUT TIMEZONE' data type). (Andy Gajetzki)

**SOAP:**

- Fixed bug php#50675 (SoapClient can't handle object references correctly). (Cameron Porter)

- Fixed bug php#76348 (WSDL_CACHE_MEMORY causes Segmentation fault). (cmb)

- Fixed bug php#77141 (Signedness issue in SOAP when precision=-1). (cmb)

**Sockets:**

- Fixed bug php#67619 (Validate length on socket_write).
(thiagooak)

----

**From upstream**

**IMAP**

- Fix php#77020 NULL pointer dereference in imap_mail CVE-2018-19935

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora update system website.
Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected php package.

See Also

https://bodhi.fedoraproject.org/updates/FEDORA-2018-7ebfe1e6f2

Plugin Details

Severity: High

ID: 120566

File Name: fedora_2018-7ebfe1e6f2.nasl

Version: 1.7

Type: local

Agent: unix

Published: 1/3/2019

Updated: 1/6/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: High

Base Score: 8.5

Temporal Score: 7

Vector: AV:N/AC:M/Au:S/C:C/I:C/A:C

Temporal Vector: E:F/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 7

Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:F/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:php, cpe:/o:fedoraproject:fedora:29

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 12/17/2018

Vulnerability Publication Date: 11/25/2018

Exploitable With

Metasploit (php imap_open Remote Code Execution)

Reference Information

CVE: CVE-2018-19518, CVE-2018-19935