SUSE SLES15 Security Update : ovmf (SUSE-SU-2018:4155-1)

High Nessus Plugin ID 120188

Synopsis

The remote SUSE host is missing one or more security updates.

Description

This update for ovmf fixes the following issues :

Security issues fixed :

CVE-2018-3613: Fixed AuthVariable Timestamp zeroing issue on
APPEND_WRITE (bsc#1115916).

CVE-2017-5731: Fixed privilege escalation via processing of malformed
files in TianoCompress.c (bsc#1115917).

CVE-2017-5732: Fixed privilege escalation via processing of malformed
files in BaseUefiDecompressLib.c (bsc#1115917).

CVE-2017-5733: Fixed privilege escalation via heap-based buffer
overflow in MakeTable() function (bsc#1115917).

CVE-2017-5734: Fixed privilege escalation via stack-based buffer
overflow in MakeTable() function (bsc#1115917).

CVE-2017-5735: Fixed privilege escalation via heap-based buffer
overflow in Decode() function (bsc#1115917).

Non security issues fixed: Fixed an issue with the default owner of
PK/KEK/db/dbx and make the auto-enrollment only happen at the very
first time. (bsc#1117998)

Note that Tenable Network Security has extracted the preceding
description block directly from the SUSE security advisory. Tenable
has attempted to automatically clean and format it as much as possible
without introducing additional issues.

Solution

To install this SUSE Security Update use the SUSE recommended
installation methods like YaST online_update or 'zypper patch'.

Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Module for Server Applications 15:zypper in -t
patch SUSE-SLE-Module-Server-Applications-15-2018-2960=1

See Also

https://bugzilla.suse.com/show_bug.cgi?id=1115916

https://bugzilla.suse.com/show_bug.cgi?id=1115917

https://bugzilla.suse.com/show_bug.cgi?id=1117998

https://www.suse.com/security/cve/CVE-2017-5731/

https://www.suse.com/security/cve/CVE-2017-5732/

https://www.suse.com/security/cve/CVE-2017-5733/

https://www.suse.com/security/cve/CVE-2017-5734/

https://www.suse.com/security/cve/CVE-2017-5735/

https://www.suse.com/security/cve/CVE-2018-3613/

http://www.nessus.org/u?5efaacfc

Plugin Details

Severity: High

ID: 120188

File Name: suse_SU-2018-4155-1.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2019/01/02

Modified: 2019/01/02

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:ovmf, p-cpe:/a:novell:suse_linux:ovmf-tools, cpe:/o:novell:suse_linux:15

Patch Publication Date: 2018/12/17

Reference Information

CVE: CVE-2017-5731, CVE-2017-5732, CVE-2017-5733, CVE-2017-5734, CVE-2017-5735, CVE-2018-3613