SUSE SLED15 / SLES15 Security Update : MozillaFirefox (SUSE-SU-2018:3476-1)

Medium Nessus Plugin ID 120146

Synopsis

The remote SUSE host is missing one or more security updates.

Description

This update for MozillaFirefox to 60.2.2ESR fixes the following issues :

Security issues fixed :

MFSA 2018-24 :

CVE-2018-12386: A Type confusion in JavaScript allowed remote code execution (bsc#1110506)

CVE-2018-12387: Array.prototype.push stack pointer vulnerability may have enabled exploits in the sandboxed content process (bsc#1110507)

MFSA 2018-23: CVE-2018-12385: Fixed a crash in TransportSecurityInfo due to cached data (bsc#1109363)

CVE-2018-12383: Setting a master password did not delete unencrypted previously stored passwords (bsc#1107343)

Non security issues fixed: Avoid undefined behavior in IPC fd-passing code (bsc#1094767)

Fixed a startup crash affecting users migrating from older ESR releases

Clean up old NSS DB files after upgrading

Fixed an endianness problem in bindgen's handling of bitfields, which was causing Firefox to crash on startup on big-endian machines. Also, updates the cc crate, which was buggy in the version that was originally vendored in. (bsc#1109465)

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or 'zypper patch'.

Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Module for Desktop Applications 15:zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-2018-2482=1

See Also

https://bugzilla.suse.com/show_bug.cgi?id=1094767

https://bugzilla.suse.com/show_bug.cgi?id=1107343

https://bugzilla.suse.com/show_bug.cgi?id=1109363

https://bugzilla.suse.com/show_bug.cgi?id=1109465

https://bugzilla.suse.com/show_bug.cgi?id=1110506

https://bugzilla.suse.com/show_bug.cgi?id=1110507

https://www.suse.com/security/cve/CVE-2018-12383/

https://www.suse.com/security/cve/CVE-2018-12385/

https://www.suse.com/security/cve/CVE-2018-12386/

https://www.suse.com/security/cve/CVE-2018-12387/

http://www.nessus.org/u?8bc9d855

Plugin Details

Severity: Medium

ID: 120146

File Name: suse_SU-2018-3476-1.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2019/01/02

Updated: 2019/01/02

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

CVSS v3.0

Base Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:MozillaFirefox, p-cpe:/a:novell:suse_linux:MozillaFirefox-branding-SLE, p-cpe:/a:novell:suse_linux:MozillaFirefox-debuginfo, p-cpe:/a:novell:suse_linux:MozillaFirefox-debugsource, p-cpe:/a:novell:suse_linux:MozillaFirefox-devel, p-cpe:/a:novell:suse_linux:MozillaFirefox-translations-common, p-cpe:/a:novell:suse_linux:MozillaFirefox-translations-other, cpe:/o:novell:suse_linux:15

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2018/10/25

Reference Information

CVE: CVE-2018-12383, CVE-2018-12385, CVE-2018-12386, CVE-2018-12387