SUSE SLES12 Security Update : nodejs4 (SUSE-SU-2018:0002-1)

Medium Nessus Plugin ID 120012

Synopsis

The remote SUSE host is missing one or more security updates.

Description

This update for nodejs4 fixes the following issues: Security issues fixed :

- CVE-2017-15896: Vulnerable to CVE-2017-3737 due to embedded OpenSSL (bsc#1072322).

- CVE-2017-14919: Embedded zlib issue could cause a DoS via specific windowBits value.

- CVE-2017-3738: Embedded OpenSSL is vulnerable to rsaz_1024_mul_avx2 overflow bug on x86_64.

- CVE-2017-3736: Embedded OpenSSL is vulnerable to bn_sqrx8x_internal carry bug on x86_64 (bsc#1066242).

- CVE-2017-3735: Embedded OpenSSL is vulnerable to malformed X.509 IPAdressFamily that could cause OOB read (bsc#1056058). Bug fixes :

- Update to release 4.8.7 (bsc#1072322):
https://nodejs.org/en/blog/vulnerability/december-2017-s ecurity-releases/

- https://nodejs.org/en/blog/release/v4.8.7/

- https://nodejs.org/en/blog/release/v4.8.6/

- https://nodejs.org/en/blog/release/v4.8.5/

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Module for Web Scripting 12:zypper in -t patch SUSE-SLE-Module-Web-Scripting-12-2018-2=1

SUSE Enterprise Storage 4:zypper in -t patch SUSE-Storage-4-2018-2=1

To bring your system up-to-date, use 'zypper patch'.

See Also

https://bugzilla.suse.com/show_bug.cgi?id=1056058

https://bugzilla.suse.com/show_bug.cgi?id=1066242

https://bugzilla.suse.com/show_bug.cgi?id=1072322

https://nodejs.org/en/blog/release/v4.8.5/

https://nodejs.org/en/blog/release/v4.8.6/

https://nodejs.org/en/blog/release/v4.8.7/

http://www.nessus.org/u?23d8f9db

https://www.suse.com/security/cve/CVE-2017-14919/

https://www.suse.com/security/cve/CVE-2017-15896/

https://www.suse.com/security/cve/CVE-2017-3735/

https://www.suse.com/security/cve/CVE-2017-3736/

https://www.suse.com/security/cve/CVE-2017-3738/

http://www.nessus.org/u?0be78ee5

Plugin Details

Severity: Medium

ID: 120012

File Name: suse_SU-2018-0002-1.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2019/01/02

Updated: 2019/09/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

CVSS v3.0

Base Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:nodejs4, p-cpe:/a:novell:suse_linux:nodejs4-debuginfo, p-cpe:/a:novell:suse_linux:nodejs4-debugsource, p-cpe:/a:novell:suse_linux:nodejs4-devel, p-cpe:/a:novell:suse_linux:npm4, cpe:/o:novell:suse_linux:12

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2018/01/02

Vulnerability Publication Date: 2017/08/28

Reference Information

CVE: CVE-2017-14919, CVE-2017-15896, CVE-2017-3735, CVE-2017-3736, CVE-2017-3737, CVE-2017-3738