pfSense 2.3.x <= 2.3.5-p2 / 2.4.x < 2.4.4 Multiple Vulnerabilities (SA-18_06 / SA-18_07 / SA-18_08)

high Nessus Plugin ID 119887


The remote firewall host is affected by multiple vulnerabilities.


According to its self-reported version number, the remote pfSense install is a version 2.3.x prior or equal to 2.3.5-p2 or 2.4.x prior to 2.4.3-p1. It is, therefore, affected by multiple vulnerabilities:

- Systems with microprocessors utilizing speculative execution and address translations may allow unauthorized disclosure of information residing in the L1 data cache to an attacker with local user access via a terminal page fault and a side-channel analysis. (CVE-2018-3620)
- An authenticated command injection vulnerability exists in status_interfaces.php via dhcp_relinquish_lease() in pfSense before 2.4.4. This allows an authenticated WebGUI user with privileges for the affected page to execute commands in the context of the root user when submitting a request to relinquish a DHCP lease for an interface which is configured to obtain its address via DHCP. (CVE-2018-16055)
- a denial of service vulnerability exists in the ip fragment reassembly code due to excessive system resource consumption. This issue can allow a remote attacker who is able to send arbitrary ip fragments to cause the machine to consume excessive resources. (CVE-2018-6923)


Upgrade to pfSense version 2.4.4 or later, or apply patches as noted in the vendor advisory.

See Also

Plugin Details

Severity: High

ID: 119887

File Name: pfsense_SA-18_08.nasl

Version: 1.4

Type: remote

Family: Firewalls

Published: 12/27/2018

Updated: 10/31/2019

Risk Information


Risk Factor: Medium

Score: 6


Risk Factor: High

Base Score: 9

Temporal Score: 7.4

Vector: AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: E:F/RL:OF/RC:C

CVSS Score Source: CVE-2018-16055


Risk Factor: High

Base Score: 8.8

Temporal Score: 8.2

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense

Required KB Items: Host/pfSense

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 8/9/2018

Vulnerability Publication Date: 8/9/2018

Exploitable With


Reference Information

CVE: CVE-2018-3620, CVE-2018-3646, CVE-2018-6922, CVE-2018-6923, CVE-2018-6924, CVE-2018-14526, CVE-2018-15473, CVE-2018-16055