pfSense 2.3.x <= 2.3.5-p2 / 2.4.x < 2.4.4 Multiple Vulnerabilities (SA-18_06 / SA-18_07 / SA-18_08)

High Nessus Plugin ID 119887

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 5.9

Synopsis

The remote firewall host is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the remote pfSense install is a version 2.3.x prior or equal to 2.3.5-p2 or 2.4.x prior to 2.4.3-p1. It is, therefore, affected by multiple vulnerabilities:

- Systems with microprocessors utilizing speculative execution and address translations may allow unauthorized disclosure of information residing in the L1 data cache to an attacker with local user access via a terminal page fault and a side-channel analysis. (CVE-2018-3620)
- An authenticated command injection vulnerability exists in status_interfaces.php via dhcp_relinquish_lease() in pfSense before 2.4.4. This allows an authenticated WebGUI user with privileges for the affected page to execute commands in the context of the root user when submitting a request to relinquish a DHCP lease for an interface which is configured to obtain its address via DHCP. (CVE-2018-16055)
- a denial of service vulnerability exists in the ip fragment reassembly code due to excessive system resource consumption. This issue can allow a remote attacker who is able to send arbitrary ip fragments to cause the machine to consume excessive resources. (CVE-2018-6923)

Solution

Upgrade to pfSense version 2.4.4 or later, or apply patches as noted in the vendor advisory.

See Also

http://www.nessus.org/u?c44a2d3c

http://www.nessus.org/u?b33cf0ad

http://www.nessus.org/u?db4f32a9

http://www.nessus.org/u?7d4d989a

Plugin Details

Severity: High

ID: 119887

File Name: pfsense_SA-18_08.nasl

Version: 1.4

Type: remote

Family: Firewalls

Published: 2018/12/27

Updated: 2019/10/31

Dependencies: 106952

Risk Information

Risk Factor: High

VPR Score: 5.9

CVSS Score Source: CVE-2018-16055

CVSS v2.0

Base Score: 9

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 8.2

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense

Required KB Items: Host/pfSense

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/08/09

Vulnerability Publication Date: 2018/08/09

Exploitable With

CANVAS (CANVAS)

Reference Information

CVE: CVE-2018-3620, CVE-2018-3646, CVE-2018-6922, CVE-2018-6923, CVE-2018-6924, CVE-2018-14526, CVE-2018-15473, CVE-2018-16055