pfSense 2.3.x < 2.3.5-p2 / 2.4.x < 2.4.3-p1 Multiple Vulnerabilities (SA-18_04 / SA-18_05)

High Nessus Plugin ID 119886

Synopsis

The remote firewall host is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the remote pfSense install is a version 2.3.x prior to 2.3.5-p2 or 2.4.x prior to 2.4.3-p1. It is, therefore, affected by multiple vulnerabilities:

- In FreeBSD before 11.1-STABLE(r332066) and 11.1-RELEASE-p10, due to insufficient initialization of memory copied to userland in the network subsystem, small amounts of kernel memory may be disclosed to userland processes. Unprivileged authenticated local users may be able to access small amounts of privileged kernel data. (CVE-2018-6921)
- A statement in the System Programming Guide of the Intel 64 and IA-32 Architectures Software Developer's Manual (SDM) was mishandled in the development of some or all operating-system kernels, resulting in unexpected behavior for #DB exceptions that could lead to local privilege escalation. (CVE-2018-8897)

Solution

Upgrade to pfSense version 2.3.5-p2 / 2.4.3-p1 or later.

See Also

http://www.nessus.org/u?74fc852c

http://www.nessus.org/u?3dd41163

http://www.nessus.org/u?4a4454c4

Plugin Details

Severity: High

ID: 119886

File Name: pfsense_SA-18_05.nasl

Version: 1.3

Type: remote

Family: Firewalls

Published: 2018/12/27

Updated: 2019/04/05

Dependencies: 106952

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-8897

CVSS v2.0

Base Score: 7.2

Temporal Score: 6.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSS v3.0

Base Score: 7.8

Temporal Score: 7.5

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense

Required KB Items: Host/pfSense

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/05/01

Vulnerability Publication Date: 2018/05/01

Exploitable With

Metasploit (Microsoft Windows POP/MOV SS Local Privilege Elevation Vulnerability)

Reference Information

CVE: CVE-2018-6920, CVE-2018-6921, CVE-2018-8897