openSUSE Security Update : perl (openSUSE-2018-1595)

High Nessus Plugin ID 119863

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for perl fixes the following issues :

Secuirty issues fixed :

- CVE-2018-18311: Fixed integer overflow with oversize environment (bsc#1114674).

- CVE-2018-18312: Fixed heap-buffer-overflow write / reg_node overrun (bsc#1114675).

- CVE-2018-18313: Fixed heap-buffer-overflow read if regex contains \0 chars (bsc#1114681).

- CVE-2018-18314: Fixed heap-buffer-overflow in regex (bsc#1114686).

This update was imported from the SUSE:SLE-15:Update update project.

Solution

Update the affected perl packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1114674

https://bugzilla.opensuse.org/show_bug.cgi?id=1114675

https://bugzilla.opensuse.org/show_bug.cgi?id=1114681

https://bugzilla.opensuse.org/show_bug.cgi?id=1114686

Plugin Details

Severity: High

ID: 119863

File Name: openSUSE-2018-1595.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2018/12/24

Modified: 2018/12/31

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:perl, p-cpe:/a:novell:opensuse:perl-32bit, p-cpe:/a:novell:opensuse:perl-32bit-debuginfo, p-cpe:/a:novell:opensuse:perl-base, p-cpe:/a:novell:opensuse:perl-base-32bit, p-cpe:/a:novell:opensuse:perl-base-32bit-debuginfo, p-cpe:/a:novell:opensuse:perl-base-debuginfo, p-cpe:/a:novell:opensuse:perl-debuginfo, p-cpe:/a:novell:opensuse:perl-debugsource, cpe:/o:novell:opensuse:15.0

Patch Publication Date: 2018/12/22

Reference Information

CVE: CVE-2018-18311, CVE-2018-18312, CVE-2018-18313, CVE-2018-18314