Cisco ASA Privilege Escalation Vulnerability (cisco-sa-20181219-asa-privesc)

Medium Nessus Plugin ID 119844

Synopsis

The remote device is missing a vendor-supplied security patch.

Description

According to its self-reported version the Cisco Adaptive Security Appliance (ASA) software running on the remote device is affected by a privilege escalation vulnerability in web management interface due to improper validation of user privileges. An authenticated, remote attacker can exploit, by sending specific HTTP requests via HTTPS, to gain elevated privileges. Please see the included Cisco BIDs and Cisco Security Advisories for more information.

Solution

Upgrade to the relevant fixed version referenced in Cisco security advisory cisco-sa-20181219-asa-privesc.

See Also

http://www.nessus.org/u?391d8efe

Plugin Details

Severity: Medium

ID: 119844

File Name: cisco-sa-20181219-asa-privesc.nasl

Version: 1.9

Type: local

Family: CISCO

Published: 2018/12/21

Updated: 2020/04/27

Dependencies: 11936, 12634

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-15465

CVSS v2.0

Base Score: 5.5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:cisco:adaptive_security_appliance_software

Required KB Items: Host/Cisco/ASA, Host/Cisco/ASA/model, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/12/19

Vulnerability Publication Date: 2018/12/19

Reference Information

CVE: CVE-2018-15465

BID: 106256