Squid 188.8.131.52 <= 3.1.x <= 3.1.23 / 184.108.40.206 <= 3.2.x / 3.3.x / 3.4.x / 3.5.x <= 3.5.28 / 4.x < 4.4 Cross-Site Scripting Vulnerability (SQUID-2018:4)
Medium Nessus Plugin ID 119726
SynopsisThe remote proxy server is affected by a cross-site scripting vulnerability.
DescriptionAccording to its banner, the version of Squid running on the remote host is 3.1.x after or equal to 220.127.116.11 and prior or equal to 3.1.23, 3.2.x after or equal to 18.104.22.168, 3.3.x, 3.4.x, 3.5.x prior or equal to 3.5.28, or 4.x prior to 4.4. It is, therefore, affected by a cross-site scripting (XSS) vulnerability due to improper validation of user-supplied input before returning it to users. A remote attacker controlled server can exploit this, by triggering error page delivery to a client with injected arbitrary script code that will execute in the client's browser session.
Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.
SolutionUpgrade to Squid version 4.4 or later. Alternatively, apply the vendor-supplied patch.