Squid 3.1.12.1 <= 3.1.x <= 3.1.23 / 3.2.0.4 <= 3.2.x / 3.3.x / 3.4.x / 3.5.x <= 3.5.28 / 4.x < 4.4 Cross-Site Scripting Vulnerability (SQUID-2018:4)

Medium Nessus Plugin ID 119726

Synopsis

The remote proxy server is affected by a cross-site scripting vulnerability.

Description

According to its banner, the version of Squid running on the remote host is 3.1.x after or equal to 3.1.12.1 and prior or equal to 3.1.23, 3.2.x after or equal to 3.2.0.4, 3.3.x, 3.4.x, 3.5.x prior or equal to 3.5.28, or 4.x prior to 4.4. It is, therefore, affected by a cross-site scripting (XSS) vulnerability due to improper validation of user-supplied input before returning it to users. A remote attacker controlled server can exploit this, by triggering error page delivery to a client with injected arbitrary script code that will execute in the client's browser session.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Squid version 4.4 or later. Alternatively, apply the vendor-supplied patch.

See Also

http://www.squid-cache.org/Advisories/SQUID-2018_4.txt

Plugin Details

Severity: Medium

ID: 119726

File Name: squid_2018_4.nasl

Version: 1.1

Type: remote

Family: Firewalls

Published: 2018/12/17

Updated: 2018/12/17

Dependencies: 49692

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-19131

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS v3.0

Base Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Required KB Items: installed_sw/Squid, Settings/ParanoidReport

Patch Publication Date: 2016/10/17

Vulnerability Publication Date: 2018/10/28

Reference Information

CVE: CVE-2018-19131