Squid <= 3.1.x <= 3.1.23 / <= 3.2.x / 3.3.x / 3.4.x / 3.5.x <= 3.5.28 / 4.x < 4.4 Cross-Site Scripting Vulnerability (SQUID-2018:4)

medium Nessus Plugin ID 119726


The remote proxy server is affected by a cross-site scripting vulnerability.


According to its banner, the version of Squid running on the remote host is 3.1.x after or equal to and prior or equal to 3.1.23, 3.2.x after or equal to, 3.3.x, 3.4.x, 3.5.x prior or equal to 3.5.28, or 4.x prior to 4.4. It is, therefore, affected by a cross-site scripting (XSS) vulnerability due to improper validation of user-supplied input before returning it to users. A remote attacker controlled server can exploit this, by triggering error page delivery to a client with injected arbitrary script code that will execute in the client's browser session.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Squid version 4.4 or later. Alternatively, apply the vendor-supplied patch.

See Also


Plugin Details

Severity: Medium

ID: 119726

File Name: squid_2018_4.nasl

Version: 1.2

Type: remote

Family: Firewalls

Published: 12/17/2018

Updated: 10/31/2019

Configuration: Enable paranoid mode

Risk Information


Risk Factor: Low

Score: 3


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2018-19131


Risk Factor: Medium

Base Score: 6.1

Temporal Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Required KB Items: installed_sw/Squid, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 10/17/2016

Vulnerability Publication Date: 10/28/2018

Reference Information

CVE: CVE-2018-19131