Squid 3.x < 3.5.28 / 4.x < 4.0.23 Multiple Denial of Service Vulnerabilities (SQUID-2018:1) (SQUID-2018:2)

Medium Nessus Plugin ID 119724

Synopsis

The remote proxy server is affected by multiple vulnerabilities.

Description

According to its banner, the version of Squid running on the remote host is 3.x prior to 3.5.28, or 4.x prior to 4.0.23. It is, therefore, affected by multiple vulnerabilities:

- A denial of service (DoS) vulnerability exists in the ESI response processing component due to incorrect pointer handling.
A remote attacker controlled server can exploit this issue, via a crafted ESI response, to cause a denial of service for all clients accessing the Squid service (CVE-2018-1000024)

- A denial of service (DoS) vulnerability exists in the HTTP message processing component due to incorrect pointer handling.
An unauthenticated remote attacker can exploit this issue, via a crafted HTTP request, to cause a denial of service for all clients accessing the Squid service (CVE-2018-1000027)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Squid version 3.5.28 or 4.0.23 or later. Alternatively, apply the vendor-supplied patch.

See Also

http://www.squid-cache.org/Advisories/SQUID-2018_1.txt

http://www.squid-cache.org/Advisories/SQUID-2018_2.txt

Plugin Details

Severity: Medium

ID: 119724

File Name: squid_2018_2.nasl

Version: 1.2

Type: remote

Family: Firewalls

Published: 2018/12/17

Updated: 2019/10/31

Dependencies: 49692

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-1000024

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Required KB Items: installed_sw/Squid, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/01/18

Vulnerability Publication Date: 2018/01/21

Reference Information

CVE: CVE-2018-1000024, CVE-2018-1000027