Squid 3.x < 3.5.18 / 4.x < 4.0.10 Multiple Denial of Service Vulnerabilities (SQUID-2016:9)

Medium Nessus Plugin ID 119723


The remote proxy server is affected by multiple denial of service vulnerabilities.


According to its banner, the version of Squid running on the remote host is 3.x prior to 3.5.18, or 4.x prior to 4.0.10. It is, therefore, affected by multiple denial of service (DoS) vulnerabilities in the ESI response processing component due to incorrect pointer handling and reference counting. A remote attacker controlled server can exploit this issue, via crafted ESI responses, to cause a denial of service for all clients accessing the Squid service.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Squid version 3.5.18 or 4.0.10 or later. Alternatively, apply the vendor-supplied patch.

See Also


Plugin Details

Severity: Medium

ID: 119723

File Name: squid_2016_9.nasl

Version: 1.1

Type: remote

Family: Firewalls

Published: 2018/12/17

Updated: 2018/12/17

Dependencies: 49692

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2016-4555

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Required KB Items: installed_sw/Squid, Settings/ParanoidReport

Patch Publication Date: 2016/05/06

Vulnerability Publication Date: 2016/05/06

Reference Information

CVE: CVE-2016-4555, CVE-2016-4556