Squid 3.x < 3.5.18 / 4.x < 4.0.10 Multiple Denial of Service Vulnerabilities (SQUID-2016:9)

high Nessus Plugin ID 119723

Synopsis

The remote proxy server is affected by multiple denial of service vulnerabilities.

Description

According to its banner, the version of Squid running on the remote host is 3.x prior to 3.5.18, or 4.x prior to 4.0.10. It is, therefore, affected by multiple denial of service (DoS) vulnerabilities in the ESI response processing component due to incorrect pointer handling and reference counting. A remote attacker controlled server can exploit this issue, via crafted ESI responses, to cause a denial of service for all clients accessing the Squid service.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Squid version 3.5.18 or 4.0.10 or later. Alternatively, apply the vendor-supplied patch.

See Also

http://www.squid-cache.org/Advisories/SQUID-2016_9.txt

Plugin Details

Severity: High

ID: 119723

File Name: squid_2016_9.nasl

Version: 1.2

Type: remote

Family: Firewalls

Published: 12/17/2018

Updated: 10/31/2019

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2016-4555

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Required KB Items: installed_sw/Squid, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 5/6/2016

Vulnerability Publication Date: 5/6/2016

Reference Information

CVE: CVE-2016-4555, CVE-2016-4556