FreeBSD : FreeBSD -- Insufficient bounds checking in bhyve(8) device model (32498c8f-fc84-11e8-be12-a4badb2f4699)

Medium Nessus Plugin ID 119563

Synopsis

The remote FreeBSD host is missing a security-related update.

Description

Insufficient bounds checking in one of the device models provided by bhyve(8) can permit a guest operating system to overwrite memory in the bhyve(8) processing possibly permitting arbitary code execution.
Impact : A guest OS using a firmware image can cause the bhyve process to crash, or possibly execute arbitrary code on the host as root.

Solution

Update the affected package.

See Also

http://www.nessus.org/u?5057ebae

Plugin Details

Severity: Medium

ID: 119563

File Name: freebsd_pkg_32498c8ffc8411e8be12a4badb2f4699.nasl

Version: 1.8

Type: local

Published: 2018/12/11

Updated: 2019/03/25

Dependencies: 12634

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-17160

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS v3.0

Base Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:FreeBSD, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info, Settings/ParanoidReport

Patch Publication Date: 2018/12/10

Vulnerability Publication Date: 2018/12/04

Reference Information

CVE: CVE-2018-1716

FreeBSD: SA-18:14.bhyve