FreeBSD : Flash Player -- multiple vulnerabilities (49cbe200-f92a-11e8-a89d-d43d7ef03aa6)

High Nessus Plugin ID 119481

Synopsis

The remote FreeBSD host is missing a security-related update.

Description

Adobe reports :

- This update resolves a use-after-free vulnerability that could lead to arbitrary code execution (CVE-2018-15982).

- This update resolves an insecure library loading vulnerability that could lead to privilege escalation (CVE-2018-15983).

Solution

Update the affected package.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb18-42.html

http://www.nessus.org/u?feb5d52b

Plugin Details

Severity: High

ID: 119481

File Name: freebsd_pkg_49cbe200f92a11e8a89dd43d7ef03aa6.nasl

Version: 1.2

Type: local

Published: 2018/12/07

Modified: 2018/12/10

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:linux-flashplayer, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/12/06

Vulnerability Publication Date: 2018/12/05

Reference Information

CVE: CVE-2018-15982, CVE-2018-15983