SUSE SLED12 / SLES12 Security Update : ncurses (SUSE-SU-2018:3967-1)

High Nessus Plugin ID 119335

Synopsis

The remote SUSE host is missing one or more security updates.

Description

This update for ncurses fixes the following issue :

Security issue fixed :

CVE-2018-19211: Fixed denial of service issue that was triggered by a NULL pointer dereference at function _nc_parse_entry (bsc#1115929).

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or 'zypper patch'.

Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Software Development Kit 12-SP4:zypper in -t patch SUSE-SLE-SDK-12-SP4-2018-2824=1

SUSE Linux Enterprise Software Development Kit 12-SP3:zypper in -t patch SUSE-SLE-SDK-12-SP3-2018-2824=1

SUSE Linux Enterprise Server 12-SP4:zypper in -t patch SUSE-SLE-SERVER-12-SP4-2018-2824=1

SUSE Linux Enterprise Server 12-SP3:zypper in -t patch SUSE-SLE-SERVER-12-SP3-2018-2824=1

SUSE Linux Enterprise Desktop 12-SP4:zypper in -t patch SUSE-SLE-DESKTOP-12-SP4-2018-2824=1

SUSE Linux Enterprise Desktop 12-SP3:zypper in -t patch SUSE-SLE-DESKTOP-12-SP3-2018-2824=1

SUSE CaaS Platform ALL :

To install this update, use the SUSE CaaS Platform Velum dashboard. It will inform you if it detects new updates and let you then trigger updating of the complete cluster in a controlled way.

SUSE CaaS Platform 3.0 :

To install this update, use the SUSE CaaS Platform Velum dashboard. It will inform you if it detects new updates and let you then trigger updating of the complete cluster in a controlled way.

OpenStack Cloud Magnum Orchestration 7:zypper in -t patch SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2018-2824=1

See Also

https://bugzilla.suse.com/show_bug.cgi?id=1115929

https://www.suse.com/security/cve/CVE-2018-19211/

http://www.nessus.org/u?b52c5acb

Plugin Details

Severity: High

ID: 119335

File Name: suse_SU-2018-3967-1.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/12/04

Modified: 2018/12/04

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:libncurses5, p-cpe:/a:novell:suse_linux:libncurses5-debuginfo, p-cpe:/a:novell:suse_linux:libncurses6, p-cpe:/a:novell:suse_linux:libncurses6-debuginfo, p-cpe:/a:novell:suse_linux:ncurses-debugsource, p-cpe:/a:novell:suse_linux:ncurses-devel, p-cpe:/a:novell:suse_linux:ncurses-devel-debuginfo, p-cpe:/a:novell:suse_linux:ncurses-utils, p-cpe:/a:novell:suse_linux:ncurses-utils-debuginfo, p-cpe:/a:novell:suse_linux:tack, p-cpe:/a:novell:suse_linux:tack-debuginfo, p-cpe:/a:novell:suse_linux:terminfo, p-cpe:/a:novell:suse_linux:terminfo-base, cpe:/o:novell:suse_linux:12

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2018/12/03

Reference Information

CVE: CVE-2018-19211