FreeBSD : Rails -- Active Job vulnerability (f96044a2-7df9-414b-9f6b-6e5b85d06c86)

High Nessus Plugin ID 119317

Synopsis

The remote FreeBSD host is missing one or more security-related updates.

Description

Ruby on Rails blog :

Rails 4.2.11, 5.0.7.1, 5.1.6.1 and 5.2.1.1 have been released! These contain the following important security fixes, and it is recommended that users upgrade as soon as possible

CVE-2018-16476 Broken Access Control vulnerability in Active Job :
Carefully crafted user input can cause Active Job to deserialize it using GlobalId and allow an attacker to have access to information that they should not have.

Solution

Update the affected packages.

See Also

http://www.nessus.org/u?06950669

http://www.nessus.org/u?3508d46e

Plugin Details

Severity: High

ID: 119317

File Name: freebsd_pkg_f96044a27df9414b9f6b6e5b85d06c86.nasl

Version: 1.1

Type: local

Published: 2018/12/03

Modified: 2018/12/03

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:rubygem-activejob4, p-cpe:/a:freebsd:freebsd:rubygem-activejob5, p-cpe:/a:freebsd:freebsd:rubygem-activejob50, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2018/12/02

Vulnerability Publication Date: 2018/11/27

Reference Information

CVE: CVE-2018-16476