FreeBSD : moodle -- Login CSRF vulnerability (889e35f4-f6a0-11e8-82dc-fcaa147e860e)

High Nessus Plugin ID 119316

Synopsis

The remote FreeBSD host is missing one or more security-related updates.

Description

moodle reports :

The login form is not protected by a token to prevent login cross-site request forgery.

Solution

Update the affected packages.

See Also

https://moodle.org/mod/forum/discuss.php?d=378731

http://www.nessus.org/u?1ee5352d

Plugin Details

Severity: High

ID: 119316

File Name: freebsd_pkg_889e35f4f6a011e882dcfcaa147e860e.nasl

Version: 1.1

Type: local

Published: 2018/12/03

Modified: 2018/12/03

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:moodle31, p-cpe:/a:freebsd:freebsd:moodle33, p-cpe:/a:freebsd:freebsd:moodle34, p-cpe:/a:freebsd:freebsd:moodle35, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2018/12/03

Vulnerability Publication Date: 2018/11/06

Reference Information

CVE: CVE-2018-16854