FreeBSD : uriparser -- Multiple vulnerabilities (3563fae5-f60c-11e8-b513-5404a68ad561)

High Nessus Plugin ID 119315

Synopsis

The remote FreeBSD host is missing a security-related update.

Description

The upstream project reports :

* Fixed: Out-of-bounds write in uriComposeQuery* and uriComposeQueryEx* Commit 864f5d4c127def386dd5cc926ad96934b297f04e Thanks to Google Autofuzz team for the report!

* Fixed: Detect integer overflow in uriComposeQuery* and uriComposeQueryEx* Commit f76275d4a91b28d687250525d3a0c5509bbd666f Thanks to Google Autofuzz team for the report!

* Fixed: Protect uriResetUri* against acting on NULL input Commit f58c25069cf4a986fe17a80c5b38687e31feb539

Solution

Update the affected package.

See Also

https://github.com/uriparser/uriparser/blob/uriparser-0.9.0/ChangeLog

http://www.nessus.org/u?572390a5

Plugin Details

Severity: High

ID: 119315

File Name: freebsd_pkg_3563fae5f60c11e8b5135404a68ad561.nasl

Version: 1.2

Type: local

Published: 2018/12/03

Modified: 2018/12/13

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:uriparser, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2018/12/02

Vulnerability Publication Date: 2018/10/27

Reference Information

CVE: CVE-2018-19198, CVE-2018-19199, CVE-2018-19200