Samba 4.7.x < 4.7.12 / 4.8.x < 4.8.7 / 4.9.x < 4.9.3 Multiple Vulnerabilities

Medium Nessus Plugin ID 119306

Synopsis

The remote Samba server is affected by multiple vulnerabilities.

Description

The version of Samba running on the remote host is 4.7.x prior to 4.7.12, or 4.8.x prior to 4.8.7, or 4.9.x prior to 4.9.3. It is, therefore, affected by multiple vulnerabilities.

Notes:
- Refer to vendor advisories for possible workarounds.
- CVE-2018-16852 and CVE-2018-16857 only apply to 4.9.x.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Samba version 4.7.12 / 4.8.7 / 4.9.3 or later.

See Also

https://www.samba.org/samba/security/CVE-2018-14629.html

https://www.samba.org/samba/security/CVE-2018-16841.html

https://www.samba.org/samba/security/CVE-2018-16851.html

https://www.samba.org/samba/security/CVE-2018-16852.html

https://www.samba.org/samba/security/CVE-2018-16853.html

https://www.samba.org/samba/security/CVE-2018-16857.html

https://www.samba.org/samba/history/samba-4.7.12.html

https://www.samba.org/samba/history/samba-4.8.7.html

https://www.samba.org/samba/history/samba-4.9.3.html

Plugin Details

Severity: Medium

ID: 119306

File Name: samba_4_7_12.nasl

Version: 1.1

Type: remote

Family: Misc.

Published: 2018/11/30

Modified: 2018/11/30

Dependencies: 10785

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-16857

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:C

CVSS v3.0

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/NativeLanManager, SMB/samba, Settings/ParanoidReport

Patch Publication Date: 2018/11/27

Vulnerability Publication Date: 2018/11/27

Reference Information

CVE: CVE-2018-14629, CVE-2018-16841, CVE-2018-16851, CVE-2018-16852, CVE-2018-16853, CVE-2018-16857

IAVA: 2018-A-0384