Samba 4.7.x < 4.7.12 / 4.8.x < 4.8.7 / 4.9.x < 4.9.3 Multiple Vulnerabilities

Medium Nessus Plugin ID 119306


The remote Samba server is affected by multiple vulnerabilities.


The version of Samba running on the remote host is 4.7.x prior to 4.7.12, or 4.8.x prior to 4.8.7, or 4.9.x prior to 4.9.3. It is, therefore, affected by multiple vulnerabilities.

- Refer to vendor advisories for possible workarounds.
- CVE-2018-16852 and CVE-2018-16857 only apply to 4.9.x.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Samba version 4.7.12 / 4.8.7 / 4.9.3 or later.

See Also

Plugin Details

Severity: Medium

ID: 119306

File Name: samba_4_7_12.nasl

Version: 1.4

Type: remote

Family: Misc.

Published: 2018/11/30

Updated: 2019/11/01

Dependencies: 10785

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-16857

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.9

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/NativeLanManager, SMB/samba, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/11/27

Vulnerability Publication Date: 2018/11/27

Reference Information

CVE: CVE-2018-14629, CVE-2018-16841, CVE-2018-16851, CVE-2018-16852, CVE-2018-16853, CVE-2018-16857