SUSE SLES12 Security Update : dpdk (SUSE-SU-2018:3923-1)

Low Nessus Plugin ID 119283

Synopsis

The remote SUSE host is missing one or more security updates.

Description

This update for dpdk to version 16.11.8 provides the following security fix :

CVE-2018-1059: restrict untrusted guest to misuse virtio to corrupt host application (ovs-dpdk) memory which could have lead all VM to lose connectivity (bsc#1089638)

and following non-security fixes: Enable the broadcom chipset family Broadcom NetXtreme II BCM57810 (bsc#1073363)

Fix a latency problem by using cond_resched rather than schedule_timeout_interruptible (bsc#1069601)

Fix a syntax error affecting csh environment configuration (bsc#1102310)

Fixes in net/bnxt :

- Fix HW Tx checksum offload check

- Fix incorrect IO address handling in Tx

- Fix Rx ring count limitation

- Check access denied for HWRM commands

- Fix RETA size

- Fix close operation

Fixes in eal/linux :

- Fix an invalid syntax in interrupts

- Fix return codes on thread naming failure

Fixes in kni :

- Fix crash with null name

- Fix build with gcc 8.1

Fixes in net/thunderx :

- Fix build with gcc optimization on

- Avoid sq door bell write on zero packet

net/bonding: Fix MAC address reset

vhost: Fix missing increment of log cache count

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or 'zypper patch'.

Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Software Development Kit 12-SP3:zypper in -t patch SUSE-SLE-SDK-12-SP3-2018-2795=1

SUSE Linux Enterprise Server 12-SP3:zypper in -t patch SUSE-SLE-SERVER-12-SP3-2018-2795=1

See Also

https://bugzilla.suse.com/show_bug.cgi?id=1069601

https://bugzilla.suse.com/show_bug.cgi?id=1073363

https://bugzilla.suse.com/show_bug.cgi?id=1089638

https://bugzilla.suse.com/show_bug.cgi?id=1102310

https://www.suse.com/security/cve/CVE-2018-1059/

http://www.nessus.org/u?6889f865

Plugin Details

Severity: Low

ID: 119283

File Name: suse_SU-2018-3923-1.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/11/29

Modified: 2018/11/29

Dependencies: 12634

Risk Information

Risk Factor: Low

CVSS v2.0

Base Score: 2.9

Vector: CVSS2#AV:A/AC:M/Au:N/C:P/I:N/A:N

CVSS v3.0

Base Score: 6.1

Vector: CVSS:3.0/AV:A/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:dpdk, p-cpe:/a:novell:suse_linux:dpdk-debuginfo, p-cpe:/a:novell:suse_linux:dpdk-debugsource, p-cpe:/a:novell:suse_linux:dpdk-kmp-default, p-cpe:/a:novell:suse_linux:dpdk-kmp-default-debuginfo, p-cpe:/a:novell:suse_linux:dpdk-tools, cpe:/o:novell:suse_linux:12

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2018/11/27

Reference Information

CVE: CVE-2018-1059