FreeBSD : Gitlab -- Multiple vulnerabilities (8a4aba2d-f33e-11e8-9416-001b217b3468)

High Nessus Plugin ID 119271

Synopsis

The remote FreeBSD host is missing one or more security-related updates.

Description

Gitlab reports :

View Names of Private Groups

Persistent XSS in Environments

SSRF in Prometheus integration

Unauthorized Promotion of Milestones

Exposure of Confidential Issue Title

Persisent XSS in Markdown Fields via Mermaid Script

Persistent XSS in Markdown Fields via Unrecognized HTML Tags

Symlink Race Condition in Pages

Unauthorized Changes by Guest User in Issues

Unauthorized Comments on Locked Issues

Improper Enforcement of Token Scope

CRLF Injection in Project Mirroring

XSS in OAuth Authorization

SSRF in Webhooks

Send Email on Email Address Change

Workhorse Logs Contained Tokens

Unauthorized Publishing of Draft Comments

Guest Can Set Weight of a New Issue

Disclosure of Private Group's Members and Milestones

Persisent XSS in Operations

Reporter Can View Operations Page

Solution

Update the affected packages.

See Also

http://www.nessus.org/u?974abfc1

http://www.nessus.org/u?08e10f75

Plugin Details

Severity: High

ID: 119271

File Name: freebsd_pkg_8a4aba2df33e11e89416001b217b3468.nasl

Version: 1.1

Type: local

Published: 2018/11/29

Modified: 2018/11/29

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:gitlab-ce, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2018/11/28

Vulnerability Publication Date: 2018/11/28

Reference Information

CVE: CVE-2018-19493, CVE-2018-19494, CVE-2018-19495, CVE-2018-19496, CVE-2018-19569, CVE-2018-19570, CVE-2018-19571, CVE-2018-19572, CVE-2018-19573, CVE-2018-19574, CVE-2018-19575, CVE-2018-19576, CVE-2018-19577, CVE-2018-19578, CVE-2018-19579, CVE-2018-19580, CVE-2018-19581, CVE-2018-19582, CVE-2018-19583, CVE-2018-19584, CVE-2018-19585