Debian DLA-1596-1 : squid3 security update

Medium Nessus Plugin ID 119153

Synopsis

The remote Debian host is missing a security update.

Description

It was discovered that there can be a denial of service (DoS) vulnerability in squid3 due to a memory leak in SNMP query rejection code when SNMP is enabled. In environments where per-process memory restrictions are not enforced strictly, a remote attacker to consume all memory available to the Squid process, causing it to crash.

For Debian 8 'Jessie', this problem has been fixed in version 3.4.8-6+deb8u6.

We recommend that you upgrade your squid3 packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/11/msg00032.html

https://packages.debian.org/source/jessie/squid3

Plugin Details

Severity: Medium

ID: 119153

File Name: debian_DLA-1596.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2018/11/27

Modified: 2018/12/13

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 5.9

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:squid-cgi, p-cpe:/a:debian:debian_linux:squid-purge, p-cpe:/a:debian:debian_linux:squid3, p-cpe:/a:debian:debian_linux:squid3-common, p-cpe:/a:debian:debian_linux:squid3-dbg, p-cpe:/a:debian:debian_linux:squidclient, cpe:/o:debian:debian_linux:8.0

Patch Publication Date: 2018/11/26

Reference Information

CVE: CVE-2018-19132