CVE-2018-19132

MEDIUM
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Squid before 4.4, when SNMP is enabled, allows a denial of service (Memory Leak) via an SNMP packet.

References

http://www.squid-cache.org/Advisories/SQUID-2018_5.txt

http://www.squid-cache.org/Versions/v5/changesets/squid-5-644131ff1e00c1895d77561f561d29c104ba6b11.patch

https://github.com/squid-cache/squid/pull/313

https://lists.debian.org/debian-lts-announce/2018/11/msg00032.html

https://lists.debian.org/debian-lts-announce/2020/07/msg00009.html

https://usn.ubuntu.com/4059-1/

Details

Source: MITRE

Published: 2018-11-09

Updated: 2020-07-11

Type: CWE-772

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 5.9

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 2.2

Severity: MEDIUM

Tenable Plugins

View all (15 total)

IDNameProductFamilySeverity
142152EulerOS 2.0 SP8 : squid (EulerOS-SA-2020-2323)NessusHuawei Local Security Checks
medium
131599EulerOS 2.0 SP2 : squid (EulerOS-SA-2019-2445)NessusHuawei Local Security Checks
critical
130693EulerOS 2.0 SP5 : squid (EulerOS-SA-2019-2231)NessusHuawei Local Security Checks
high
126749Ubuntu 16.04 LTS / 18.04 LTS / 19.04 : Squid vulnerabilities (USN-4059-1)NessusUbuntu Local Security Checks
medium
123382openSUSE Security Update : squid (openSUSE-2019-936)NessusSuSE Local Security Checks
medium
123084Amazon Linux AMI : squid (ALAS-2019-1176)NessusAmazon Linux Local Security Checks
medium
122217EulerOS 2.0 SP3 : squid (EulerOS-SA-2019-1044)NessusHuawei Local Security Checks
medium
120523Fedora 29 : 7:squid (2018-714298460e)NessusFedora Local Security Checks
medium
120164SUSE SLES15 Security Update : squid (SUSE-SU-2018:3786-1)NessusSuSE Local Security Checks
medium
119727Squid 3.2.0.10 <= 3.2.x / 3.3.x / 3.4.x / 3.5.x <= 3.5.28 / 4.x < 4.4 Denial of Service Vulnerability (SQUID-2018:5)NessusFirewalls
medium
119554SUSE SLES12 Security Update : squid (SUSE-SU-2018:3771-2)NessusSuSE Local Security Checks
medium
119153Debian DLA-1596-1 : squid3 security updateNessusDebian Local Security Checks
medium
119079openSUSE Security Update : squid (openSUSE-2018-1429)NessusSuSE Local Security Checks
medium
119078openSUSE Security Update : squid (openSUSE-2018-1428)NessusSuSE Local Security Checks
medium
119012SUSE SLES12 Security Update : squid (SUSE-SU-2018:3771-1)NessusSuSE Local Security Checks
medium