openSUSE Security Update : libwpd (openSUSE-2018-1463)

High Nessus Plugin ID 119138

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for libwpd fixes the following issues :

Security issue fixed :

- CVE-2018-19208: illegal address access inside libwpd at function WP6ContentListener:defineTable (bsc#1115713).

This update was imported from the SUSE:SLE-15:Update update project.

Solution

Update the affected libwpd packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1115713

Plugin Details

Severity: High

ID: 119138

File Name: openSUSE-2018-1463.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/11/26

Modified: 2018/11/26

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libwpd-0_10-10, p-cpe:/a:novell:opensuse:libwpd-0_10-10-debuginfo, p-cpe:/a:novell:opensuse:libwpd-debuginfo, p-cpe:/a:novell:opensuse:libwpd-debugsource, p-cpe:/a:novell:opensuse:libwpd-devel, p-cpe:/a:novell:opensuse:libwpd-tools, p-cpe:/a:novell:opensuse:libwpd-tools-debuginfo, cpe:/o:novell:opensuse:15.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2018/11/24

Reference Information

CVE: CVE-2018-19208