FreeBSD : Flash Player -- arbitrary code execution (8f128c72-ecf9-11e8-aa00-6451062f0f7a)

High Nessus Plugin ID 119057

Synopsis

The remote FreeBSD host is missing a security-related update.

Description

Adobe reports :

- This update resolves a type confusion vulnerability that could lead to arbitrary code execution (CVE-2018-15981).

Solution

Update the affected package.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb18-44.html

http://www.nessus.org/u?8e766acd

Plugin Details

Severity: High

ID: 119057

File Name: freebsd_pkg_8f128c72ecf911e8aa006451062f0f7a.nasl

Version: 1.1

Type: local

Published: 2018/11/21

Modified: 2018/11/21

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:linux-flashplayer, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2018/11/20

Vulnerability Publication Date: 2018/11/20

Reference Information

CVE: CVE-2018-15981