VMware vRealize Automation 7.0.x / 7.1.x / 7.2.x / 7.3.x < 7.3.1 DOM-based XSS Vulnerability (VMSA-2018-0009)

Medium Nessus Plugin ID 119037

Synopsis

A virtualization appliance installed on the remote host is affected by DOM-based XSS vulnerability.

Description

The version of VMware vRealize Automation installed on the remote host is 7.0.x, 7.1.x, 7.2.x, or 7.3.x < 7.3.1. It is, therefore, affected by vulnerability that may allow for a DOM-based cross-site scripting (XSS) attack. Exploitation of this issue may lead to the compromise of the vRA user's workstation.

Solution

Upgrade to VMware vRealize Automation version 7.3.1 or later.

See Also

https://www.vmware.com/security/advisories/VMSA-2018-0009.html

Plugin Details

Severity: Medium

ID: 119037

File Name: vmware_vsphere_vrealize_automation_vmsa-2018-0009_CVE-2018-6958.nasl

Version: 1.1

Type: local

Published: 2018/11/19

Modified: 2018/11/19

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-6958

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS v3.0

Base Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Vulnerability Information

CPE: cpe:/a:vmware:vrealize_automation

Required KB Items: Host/VMware vRealize Automation/Version

Patch Publication Date: 2018/04/13

Vulnerability Publication Date: 2018/04/13

Reference Information

CVE: CVE-2018-6958

BID: 103752

VMSA: 2018-0009