VMware vRealize Automation 7.0.x / 7.1.x / 7.2.x / 7.3.x < 7.3.1 DOM-based XSS Vulnerability (VMSA-2018-0009)

Medium Nessus Plugin ID 119037


A virtualization appliance installed on the remote host is affected by DOM-based XSS vulnerability.


The version of VMware vRealize Automation installed on the remote host is 7.0.x, 7.1.x, 7.2.x, or 7.3.x < 7.3.1. It is, therefore, affected by vulnerability that may allow for a DOM-based cross-site scripting (XSS) attack. Exploitation of this issue may lead to the compromise of the vRA user's workstation.


Upgrade to VMware vRealize Automation version 7.3.1 or later.

See Also


Plugin Details

Severity: Medium

ID: 119037

File Name: vmware_vsphere_vrealize_automation_vmsa-2018-0009_CVE-2018-6958.nasl

Version: 1.2

Type: local

Published: 2018/11/19

Updated: 2019/11/01

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-6958

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 6.1

Temporal Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:vrealize_automation

Required KB Items: Host/VMware vRealize Automation/Version

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/04/13

Vulnerability Publication Date: 2018/04/13

Reference Information

CVE: CVE-2018-6958

BID: 103752

VMSA: 2018-0009