Node.js multiple vulnerabilities (July 2018 Security Releases).

High Nessus Plugin ID 118957

Synopsis

Node.js - JavaScript run-time environment is affected by multiple vulnerabilities.

Description

The version of Node.js installed on the remote host is 6.x prior to 6.14.3, 8.x prior to 8.11.3, 9.x prior to 9.11.2 or 10.x prior to 10.4.1.
It, therefore, is affected by multiple vulnerabilities.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade Node.js to a recommended by vendor version or above

See Also

http://www.nessus.org/u?a072ed2c

Plugin Details

Severity: High

ID: 118957

File Name: nodejs_2018_jul.nasl

Version: 1.1

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 2018/11/14

Updated: 2018/11/14

Dependencies: 11936, 110839

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-7162

CVSS v2.0

Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/a:nodejs:node.js

Required KB Items: Settings/ParanoidReport

Patch Publication Date: 2018/06/12

Vulnerability Publication Date: 2018/06/12

Reference Information

CVE: CVE-2018-1000168, CVE-2018-7161, CVE-2018-7162, CVE-2018-7164, CVE-2018-7167

BID: 103952, 104468, 104463