CVE-2018-7164

MEDIUM

Description

Node.js versions 9.7.0 and later and 10.x are vulnerable and the severity is MEDIUM. A bug introduced in 9.7.0 increases the memory consumed when reading from the network into JavaScript using the net.Socket object directly as a stream. An attacker could use this cause a denial of service by sending tiny chunks of data in short succession. This vulnerability was restored by reverting to the prior behaviour.

References

http://www.securityfocus.com/bid/104463

https://nodejs.org/en/blog/vulnerability/june-2018-security-releases/

https://security.gentoo.org/glsa/202003-48

Details

Source: MITRE

Published: 2018-06-13

Updated: 2020-03-20

Type: CWE-400

Risk Information

CVSS v2.0

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:* versions from 9.7.0 to 10.7.0 (inclusive)

Tenable Plugins

View all (3 total)

IDNameProductFamilySeverity
134776GLSA-202003-48 : Node.js: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
118957Node.js multiple vulnerabilities (July 2018 Security Releases).NessusMisc.
high
110539FreeBSD : node.js -- multiple vulnerabilities (45b8e2eb-7056-11e8-8fab-63ca6e0e13a2)NessusFreeBSD Local Security Checks
high