SUSE SLES11 Security Update : opensc (SUSE-SU-2018:3621-1)

Medium Nessus Plugin ID 118748

Synopsis

The remote SUSE host is missing one or more security updates.

Description

This update for opensc fixes the following issues :

CVE-2018-16391: Fixed a denial of service when handling responses from
a Muscle Card (bsc#1106998)

CVE-2018-16392: Fixed a denial of service when handling responses from
a TCOS Card (bsc#1106999)

CVE-2018-16393: Fixed buffer overflows when handling responses from
Gemsafe V1 Smartcards (bsc#1108318)

CVE-2018-16418: Fixed buffer overflow when handling string
concatenation in util_acl_to_str (bsc#1107039)

CVE-2018-16419: Fixed several buffer overflows when handling responses
from a Cryptoflex card (bsc#1107107)

CVE-2018-16422: Fixed single byte buffer overflow when handling
responses from an esteid Card (bsc#1107038)

CVE-2018-16423: Fixed double free when handling responses from a
smartcard (bsc#1107037)

CVE-2018-16427: Fixed out of bounds reads when handling responses in
OpenSC (bsc#1107033)

Note that Tenable Network Security has extracted the preceding
description block directly from the SUSE security advisory. Tenable
has attempted to automatically clean and format it as much as possible
without introducing additional issues.

Solution

To install this SUSE Security Update use the SUSE recommended
installation methods like YaST online_update or 'zypper patch'.

Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Software Development Kit 11-SP4:zypper in -t
patch sdksp4-opensc-13856=1

SUSE Linux Enterprise Server 11-SP4:zypper in -t patch
slessp4-opensc-13856=1

SUSE Linux Enterprise Debuginfo 11-SP4:zypper in -t patch
dbgsp4-opensc-13856=1

See Also

https://bugzilla.suse.com/show_bug.cgi?id=1104812

https://bugzilla.suse.com/show_bug.cgi?id=1106998

https://bugzilla.suse.com/show_bug.cgi?id=1106999

https://bugzilla.suse.com/show_bug.cgi?id=1107033

https://bugzilla.suse.com/show_bug.cgi?id=1107037

https://bugzilla.suse.com/show_bug.cgi?id=1107038

https://bugzilla.suse.com/show_bug.cgi?id=1107039

https://bugzilla.suse.com/show_bug.cgi?id=1107107

https://bugzilla.suse.com/show_bug.cgi?id=1108318

https://www.suse.com/security/cve/CVE-2018-16391/

https://www.suse.com/security/cve/CVE-2018-16392/

https://www.suse.com/security/cve/CVE-2018-16393/

https://www.suse.com/security/cve/CVE-2018-16418/

https://www.suse.com/security/cve/CVE-2018-16419/

https://www.suse.com/security/cve/CVE-2018-16422/

https://www.suse.com/security/cve/CVE-2018-16423/

https://www.suse.com/security/cve/CVE-2018-16427/

http://www.nessus.org/u?96666bfb

Plugin Details

Severity: Medium

ID: 118748

File Name: suse_SU-2018-3621-1.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2018/11/06

Modified: 2018/12/01

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 6.8

Vector: CVSS:3.0/AV:P/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:libopensc2, p-cpe:/a:novell:suse_linux:opensc, cpe:/o:novell:suse_linux:11

Patch Publication Date: 2018/11/05

Reference Information

CVE: CVE-2018-16391, CVE-2018-16392, CVE-2018-16393, CVE-2018-16418, CVE-2018-16419, CVE-2018-16422, CVE-2018-16423, CVE-2018-16427