FreeBSD : Loofah -- XSS vulnerability (36a2a89e-7ee1-4ea4-ae22-7ca38019c8d0)

Low Nessus Plugin ID 118704

Synopsis

The remote FreeBSD host is missing a security-related update.

Description

GitHub issue :

This issue has been created for public disclosure of an XSS vulnerability that was responsibly reported (independently) by Shubham Pathak and @yasinS (Yasin Soliman).

In the Loofah gem, through v2.2.2, unsanitized JavaScript may occur in sanitized output when a crafted SVG element is republished.

Solution

Update the affected package.

See Also

https://github.com/flavorjones/loofah/releases

https://github.com/flavorjones/loofah/issues/154

http://www.nessus.org/u?04b1e989

Plugin Details

Severity: Low

ID: 118704

File Name: freebsd_pkg_36a2a89e7ee14ea4ae227ca38019c8d0.nasl

Version: 1.3

Type: local

Published: 2018/11/02

Modified: 2018/12/13

Dependencies: 12634

Risk Information

Risk Factor: Low

CVSS v2.0

Base Score: 3.5

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N

CVSS v3.0

Base Score: 5.4

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:rubygem-loofah, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2018/11/01

Vulnerability Publication Date: 2018/10/30

Reference Information

CVE: CVE-2018-16468