SUSE SLED12 / SLES12 Security Update : audiofile (SUSE-SU-2018:3588-1)

High Nessus Plugin ID 118588

Synopsis

The remote SUSE host is missing one or more security updates.

Description

This update for audiofile fixes the following issues :

CVE-2018-17095: A heap-based buffer overflow in Expand3To4Module::run
could occurred when running sfconvert leading to crashes or code
execution when handling untrusted soundfiles (bsc#1111586).

Note that Tenable Network Security has extracted the preceding
description block directly from the SUSE security advisory. Tenable
has attempted to automatically clean and format it as much as possible
without introducing additional issues.

Solution

To install this SUSE Security Update use the SUSE recommended
installation methods like YaST online_update or 'zypper patch'.

Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Software Development Kit 12-SP3:zypper in -t
patch SUSE-SLE-SDK-12-SP3-2018-2542=1

SUSE Linux Enterprise Server 12-SP3:zypper in -t patch
SUSE-SLE-SERVER-12-SP3-2018-2542=1

SUSE Linux Enterprise Desktop 12-SP3:zypper in -t patch
SUSE-SLE-DESKTOP-12-SP3-2018-2542=1

See Also

https://bugzilla.suse.com/show_bug.cgi?id=1111586

https://www.suse.com/security/cve/CVE-2018-17095/

http://www.nessus.org/u?124c0577

Plugin Details

Severity: High

ID: 118588

File Name: suse_SU-2018-3588-1.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2018/11/01

Modified: 2018/12/01

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:audiofile, p-cpe:/a:novell:suse_linux:audiofile-debuginfo, p-cpe:/a:novell:suse_linux:audiofile-debugsource, p-cpe:/a:novell:suse_linux:libaudiofile1, p-cpe:/a:novell:suse_linux:libaudiofile1-debuginfo, cpe:/o:novell:suse_linux:12

Patch Publication Date: 2018/10/31

Reference Information

CVE: CVE-2018-17095