macOS : Apple Safari < 12.0.1 Multiple Vulnerabilities

High Nessus Plugin ID 118571

Synopsis

A web browser installed on the remote macOS or Mac OS X host is affected by multiple vulnerabilities.

Description

The version of Apple Safari installed on the remote macOS or Mac OS X host is prior to 12.0.1. It is, therefore, affected by multiple vulnerabilities.

Solution

Upgrade to Apple Safari version 12.0.1 or later.

See Also

https://support.apple.com/en-us/HT209196

Plugin Details

Severity: High

ID: 118571

File Name: macosx_Safari12_0_1.nasl

Version: 1.1

Type: local

Agent: macosx

Published: 2018/10/31

Modified: 2018/10/31

Dependencies: 31604

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-4372

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 6.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L

Vulnerability Information

CPE: cpe:/a:apple:safari, cpe:/o:apple:mac_os_x

Required KB Items: Host/local_checks_enabled, Host/MacOSX/Version, MacOSX/Safari/Installed

Patch Publication Date: 2018/10/30

Vulnerability Publication Date: 2018/10/30

Reference Information

CVE: CVE-2018-4374, CVE-2018-4377, CVE-2018-4372, CVE-2018-4373, CVE-2018-4375, CVE-2018-4376, CVE-2018-4382, CVE-2018-4386, CVE-2018-4392, CVE-2018-4416, CVE-2018-4409, CVE-2018-4378