FreeBSD : Gitlab -- multiple vulnerabilities (b9591212-dba7-11e8-9416-001b217b3468)

High Nessus Plugin ID 118497

Synopsis

The remote FreeBSD host is missing one or more security-related updates.

Description

Gitlab reports :

RCE in Gitlab Wiki API

SSRF in Hipchat integration

Cleartext storage of personal access tokens

Information exposure through stack trace error message

Persistent XSS autocomplete

Information exposure in stored browser history

Information exposure when replying to issues through email

Persistent XSS in License Management and Security Reports

Metrics information disclosure in Prometheus integration

Unauthorized changes to a protected branch's access levels

Solution

Update the affected packages.

See Also

http://www.nessus.org/u?9cc77cab

http://www.nessus.org/u?206b1a7d

Plugin Details

Severity: High

ID: 118497

File Name: freebsd_pkg_b9591212dba711e89416001b217b3468.nasl

Version: 1.2

Type: local

Published: 2018/10/30

Modified: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:gitlab-ce, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2018/10/29

Vulnerability Publication Date: 2018/10/29

Reference Information

CVE: CVE-2018-18640, CVE-2018-18641, CVE-2018-18642, CVE-2018-18643, CVE-2018-18644, CVE-2018-18645, CVE-2018-18646, CVE-2018-18647, CVE-2018-18648, CVE-2018-18649