FreeBSD : liveMedia -- potential remote code execution (fa194483-dabd-11e8-bf39-5404a68ad561)

High Nessus Plugin ID 118478

Synopsis

The remote FreeBSD host is missing a security-related update.

Description

Talos reports :

An exploitable code execution vulnerability exists in the HTTP packet-parsing functionality of the LIVE555 RTSP server library. A specially crafted packet can cause a stack-based buffer overflow, resulting in code execution. An attacker can send a packet to trigger this vulnerability.

Solution

Update the affected package.

See Also

https://talosintelligence.com/vulnerability_reports/TALOS-2018-0684

http://lists.live555.com/pipermail/live-devel/2018-October/021071.html

http://www.nessus.org/u?fbbf122c

Plugin Details

Severity: High

ID: 118478

File Name: freebsd_pkg_fa194483dabd11e8bf395404a68ad561.nasl

Version: 1.3

Type: local

Published: 2018/10/29

Updated: 2019/01/28

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:liveMedia, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2018/10/28

Vulnerability Publication Date: 2018/10/18

Reference Information

CVE: CVE-2018-4013