Debian DLA-1558-1 : ruby2.1 security update

High Nessus Plugin ID 118471

Synopsis

The remote Debian host is missing a security update.

Description

CVE-2018-16395 Fix for OpenSSL::X509::Name equality check.

CVE-2018-16396 Tainted flags are not propagated in Array#pack and String#unpack with some directives.

For Debian 8 'Jessie', these problems have been fixed in version 2.1.5-2+deb8u6.

We recommend that you upgrade your ruby2.1 packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/10/msg00020.html

https://packages.debian.org/source/jessie/ruby2.1

Plugin Details

Severity: High

ID: 118471

File Name: debian_DLA-1558.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/10/29

Modified: 2018/10/29

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libruby2.1, p-cpe:/a:debian:debian_linux:ruby2.1, p-cpe:/a:debian:debian_linux:ruby2.1-dev, p-cpe:/a:debian:debian_linux:ruby2.1-doc, p-cpe:/a:debian:debian_linux:ruby2.1-tcltk, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/10/28

Reference Information

CVE: CVE-2018-16395, CVE-2018-16396