Apache Tomcat 9.0.0.M1 < 9.0.12 Open Redirect Weakness

Medium Nessus Plugin ID 118037

Synopsis

The remote Apache Tomcat server is affected by a open redirect vulnerability.

Description

The version of Apache Tomcat installed on the remote host is 9.0.x prior to 9.0.12. It is, therefore, affected by a open redirect vulnerability.

Solution

Upgrade to Apache Tomcat version 9.0.12 or later.

See Also

http://www.nessus.org/u?fae4f2a1

Plugin Details

Severity: Medium

ID: 118037

File Name: tomcat_9_0_11.nasl

Version: 1.6

Type: remote

Family: Web Servers

Published: 2018/10/10

Updated: 2019/11/01

Dependencies: 39446

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-11784

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 4.3

Temporal Score: 3.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/09/19

Vulnerability Publication Date: 2018/10/03

Reference Information

CVE: CVE-2018-11784