Cisco IOS XE Software Command Injection Vulnerabilities (cisco-sa-20180926-iosxe-cmdinj)

Medium Nessus Plugin ID 117947

Synopsis

The remote device is missing a vendor-supplied security patch.

Description

According to its self-reported version, the IOS XE is affected by one or more vulnerabilities. Please see the included Cisco BIDs and the Cisco Security Advisory for more information.

Solution

Upgrade to the relevant fixed version referenced in Cisco bug ID(s) CSCvh02919 and CSCvh54202.

See Also

http://www.nessus.org/u?bffcfafc

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvh02919

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvh54202

Plugin Details

Severity: Medium

ID: 117947

File Name: cisco-sa-20180926-iosxe-cmdinj.nasl

Version: 1.2

Type: local

Family: CISCO

Published: 2018/10/05

Modified: 2018/10/05

Dependencies: 67217

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-0477

CVSS Score Rationale: Based on vendor provided score.

CVSSv2

Base Score: 6.8

Vector: CVSS2#AV:L/AC:L/Au:S/C:C/I:C/A:C

CVSSv3

Base Score: 6.7

Vector: CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/o:cpe:/o:cisco:ios_xe

Required KB Items: Host/Cisco/IOS-XE/Version

Patch Publication Date: 2018/09/26

Vulnerability Publication Date: 2018/09/26

Reference Information

CVE: CVE-2018-0477, CVE-2018-0481

CISCO-BUG-ID: CSCvh02919, CSCvh54202

CISCO-SA: cisco-sa-20180926-iosxe-cmdinj

IAVA: 2018-A-0313