openSUSE Security Update : bitcoin (openSUSE-2018-1098)

Medium Nessus Plugin ID 117929

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for bitcoin to version 0.16.3 fixes the following issues :

- CVE-2018-17144: Prevent remote denial of service (application crash) exploitable by miners via duplicate input (bsc#1108992).

For additional changes please check the changelog.

Solution

Update the affected bitcoin packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1108992

Plugin Details

Severity: Medium

ID: 117929

File Name: openSUSE-2018-1098.nasl

Version: 1.4

Type: local

Agent: unix

Published: 2018/10/05

Modified: 2018/12/11

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:bitcoin-debuginfo, p-cpe:/a:novell:opensuse:bitcoin-debugsource, p-cpe:/a:novell:opensuse:bitcoin-qt5, p-cpe:/a:novell:opensuse:bitcoin-qt5-debuginfo, p-cpe:/a:novell:opensuse:bitcoin-test, p-cpe:/a:novell:opensuse:bitcoin-test-debuginfo, p-cpe:/a:novell:opensuse:bitcoin-utils, p-cpe:/a:novell:opensuse:bitcoin-utils-debuginfo, p-cpe:/a:novell:opensuse:bitcoind, p-cpe:/a:novell:opensuse:bitcoind-debuginfo, p-cpe:/a:novell:opensuse:libbitcoinconsensus-devel, p-cpe:/a:novell:opensuse:libbitcoinconsensus0, p-cpe:/a:novell:opensuse:libbitcoinconsensus0-debuginfo, cpe:/o:novell:opensuse:15.0, cpe:/o:novell:opensuse:42.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2018/10/04

Reference Information

CVE: CVE-2018-17144