QNAP Photo Station < 5.7.0 Cross-Site Scripting Vulnerability

Medium Nessus Plugin ID 117905

Synopsis

A photo gallery application running on the remote NAS is affected by a cross-site scripting vulnerability.

Description

The version of Photo Station running on the remote QNAP NAS is prior to 5.7.0. It is, therefore, affected by a cross-site scripting vulnerability.

Solution

Upgrade to Photo Station 5.7.0 or later.

See Also

https://www.qnap.com/en-us/security-advisory/nas-201808-23

Plugin Details

Severity: Medium

ID: 117905

File Name: qnap_photostation_5_7_0.nasl

Version: 1.1

Type: remote

Published: 2018/10/03

Modified: 2018/10/03

Dependencies: 117906

Risk Information

Risk Factor: Medium

CVSS Score Source: manual

CVSS Score Rationale: Nvd score not available. score based on analysis of vendor advisory.

CVSSv2

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSSv3

Base Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/h:qnap:photo_station

Patch Publication Date: 2018/08/23

Vulnerability Publication Date: 2018/08/23

Reference Information

CVE: CVE-2018-0715